Jump to content
American MilSim
Callsign-Hammer

Baofeng UV-5r problem

Recommended Posts

My Baofeng's had a weird problem for a few months now. The buttons on the side (ptt button, flashlight button, etc.) work fine, but none of the buttons on the front face of the radio seem to function as intended. I would just assume the buttons were broken or there was some sort of wiring error, but the funny thing is that I still get a beep anytime I press any of these buttons, IE it acknowledges the buttons were pressed, they just don't actually do anything. This, of course, is problematic seeing as I cannot change frequency or access the settings menu. Anyone able to help me out? Is there a fix? Or should I invest in a new Baofeng?

Share this post


Link to post
Share on other sites

My Baofeng's had a weird problem for a few months now. The buttons on the side (ptt button, flashlight button, etc.) work fine, but none of the buttons on the front face of the radio seem to function as intended. I would just assume the buttons were broken or there was some sort of wiring error, but the funny thing is that I still get a beep anytime I press any of these buttons, IE it acknowledges the buttons were pressed, they just don't actually do anything. This, of course, is problematic seeing as I cannot change frequency or access the settings menu. Anyone able to help me out? Is there a fix? Or should I invest in a new Baofeng?

 

Did you lock the keypad by accident?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...